summaryrefslogtreecommitdiffstats
path: root/package/netplug/netplug-1.2.9.2-makefile-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/netplug/netplug-1.2.9.2-makefile-flags.patch')
-rw-r--r--package/netplug/netplug-1.2.9.2-makefile-flags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/netplug/netplug-1.2.9.2-makefile-flags.patch b/package/netplug/netplug-1.2.9.2-makefile-flags.patch
new file mode 100644
index 000000000..b2468f8c8
--- /dev/null
+++ b/package/netplug/netplug-1.2.9.2-makefile-flags.patch
@@ -0,0 +1,21 @@
+Preserve the cflags settings, because buildroot clobbers them.
+
+--- a/Makefile 2010-10-05 00:06:38.000000000 -0700
++++ b/Makefile 2010-10-05 00:15:27.000000000 -0700
+@@ -11,11 +11,14 @@ mandir ?= $(prefix)/usr/share/man
+
+ install_opts :=
+
+-CFLAGS += -Wall -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
++NETPLUG_CFLAGS += -Wall -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
+ -DNP_SCRIPT_DIR='"$(scriptdir)"' -ggdb3 -O3 -DNP_VERSION='"$(version)"'
+
++%.o: %.c
++ $(CC) $(NETPLUG_CFLAGS) $(CFLAGS) -c -o $@ $<
++
+ netplugd: config.o netlink.o lib.o if_info.o main.o
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) -o $@ $(NETPLUG_CFLAGS) $^
+
+ install:
+ install -d $(install_opts) -m 755 \