summaryrefslogtreecommitdiffstats
path: root/package/nasm
diff options
context:
space:
mode:
Diffstat (limited to 'package/nasm')
-rw-r--r--package/nasm/nasm.mk13
1 files changed, 3 insertions, 10 deletions
diff --git a/package/nasm/nasm.mk b/package/nasm/nasm.mk
index b819df04b..9d9920905 100644
--- a/package/nasm/nasm.mk
+++ b/package/nasm/nasm.mk
@@ -2,17 +2,10 @@
#
# nasm
#
-# This is special case: nasm is used to build syslinux and
-# pxelinux. As these are for the target, we should cross-compile
-# nasm. However, as nasm is x86-only, there's no point in
-# cross-compiling it. So we just build it for the host. The target
-# variant is only provided because of a bug in the package
-# infrastructure that prevents having only a host variant.
############################################################
-NASM_VERSION=2.08.01
-NASM_SOURCE=nasm-$(NASM_VERSION).tar.bz2
-NASM_SITE=http://www.nasm.us/pub/nasm/releasebuilds/2.08.01/
+NASM_VERSION = 2.10.01
+NASM_SOURCE = nasm-$(NASM_VERSION).tar.bz2
+NASM_SITE = http://www.nasm.us/pub/nasm/releasebuilds/$(NASM_VERSION)
-$(eval $(call AUTOTARGETS))
$(eval $(call AUTOTARGETS,host))