summaryrefslogtreecommitdiffstats
path: root/package/mysql_client/mysql_client-5.1.62-use-new-readline-iface.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/mysql_client/mysql_client-5.1.62-use-new-readline-iface.patch')
-rw-r--r--package/mysql_client/mysql_client-5.1.62-use-new-readline-iface.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/mysql_client/mysql_client-5.1.62-use-new-readline-iface.patch b/package/mysql_client/mysql_client-5.1.62-use-new-readline-iface.patch
new file mode 100644
index 000000000..c5906563c
--- /dev/null
+++ b/package/mysql_client/mysql_client-5.1.62-use-new-readline-iface.patch
@@ -0,0 +1,21 @@
+Tell MySQL to use the new readline interface even when an external
+readline is being used.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ configure.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: mysql-5.1.53/configure.in
+===================================================================
+--- mysql-5.1.53.orig/configure.in
++++ mysql-5.1.53/configure.in
+@@ -2689,6 +2689,7 @@
+ # this way we avoid linking commercial source with GPL readline
+ readline_link="-lreadline"
+ want_to_use_readline="yes"
++ AC_DEFINE_UNQUOTED(USE_NEW_READLINE_INTERFACE, 1)
+ elif [test "$mysql_cv_libedit_interface" = "yes"]
+ then
+ # Use libedit