summaryrefslogtreecommitdiffstats
path: root/package/multimedia/gst-plugins-base/gst-plugins-base.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/multimedia/gst-plugins-base/gst-plugins-base.mk')
-rw-r--r--package/multimedia/gst-plugins-base/gst-plugins-base.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/multimedia/gst-plugins-base/gst-plugins-base.mk b/package/multimedia/gst-plugins-base/gst-plugins-base.mk
index 91d9f1b1d..e91d5fc0d 100644
--- a/package/multimedia/gst-plugins-base/gst-plugins-base.mk
+++ b/package/multimedia/gst-plugins-base/gst-plugins-base.mk
@@ -25,8 +25,14 @@ GST_PLUGINS_BASE_CONF_OPT = \
--disable-vorbistest \
--disable-freetypetest
-GST_PLUGINS_BASE_DEPENDENCIES = gstreamer liboil \
- $(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib)
+GST_PLUGINS_BASE_DEPENDENCIES = gstreamer liboil
+
+# alsa support needs pcm+mixer support, but configure fails to check for it
+ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
+GST_PLUGINS_BASE_DEPENDENCIES += alsa-lib
+else
+GST_PLUGINS_BASE_CONF_OPT += --disable-alsa
+endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ADDER),y)
GST_PLUGINS_BASE_CONF_OPT += --enable-adder