summaryrefslogtreecommitdiffstats
path: root/package/mongrel2/mongrel2-0001-use-CC-variable-to-compile-procer.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/mongrel2/mongrel2-0001-use-CC-variable-to-compile-procer.patch')
-rw-r--r--package/mongrel2/mongrel2-0001-use-CC-variable-to-compile-procer.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/mongrel2/mongrel2-0001-use-CC-variable-to-compile-procer.patch b/package/mongrel2/mongrel2-0001-use-CC-variable-to-compile-procer.patch
new file mode 100644
index 000000000..310177aef
--- /dev/null
+++ b/package/mongrel2/mongrel2-0001-use-CC-variable-to-compile-procer.patch
@@ -0,0 +1,28 @@
+From d30cf797af4828e49fd3c0f25841e669dec05ed5 Mon Sep 17 00:00:00 2001
+From: Lionel Orry <lionel.orry@gmail.com>
+Date: Wed, 27 Mar 2013 14:02:00 +0100
+Subject: [PATCH 3/4] use CC variable to compile procer.
+
+This fixes procer tool cross-compilation issues.
+
+Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
+---
+ tools/procer/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/procer/Makefile b/tools/procer/Makefile
+index d0d7de0..bb9aa31 100644
+--- a/tools/procer/Makefile
++++ b/tools/procer/Makefile
+@@ -8,7 +8,7 @@ all: procer
+
+
+ procer: ../../build/libm2.a ${OBJECTS}
+- gcc $(OPTFLAGS) $(OPTLIBS) -o $@ ${OBJECTS} ../../build/libm2.a ${LIBS}
++ $(CC) $(OPTFLAGS) $(OPTLIBS) -o $@ ${OBJECTS} ../../build/libm2.a ${LIBS}
+
+ clean:
+ rm -f *.o procer
+--
+1.8.1.4
+