summaryrefslogtreecommitdiffstats
path: root/package/matchbox/matchbox-startup-monitor
diff options
context:
space:
mode:
Diffstat (limited to 'package/matchbox/matchbox-startup-monitor')
-rw-r--r--package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor-0.1-true-false.patch21
-rw-r--r--package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk16
2 files changed, 37 insertions, 0 deletions
diff --git a/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor-0.1-true-false.patch b/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor-0.1-true-false.patch
new file mode 100644
index 000000000..c92a0776b
--- /dev/null
+++ b/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor-0.1-true-false.patch
@@ -0,0 +1,21 @@
+mbmonitor uses TRUE / FALSE without defining them
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ mbmonitor.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+Index: mb-applet-startup-monitor-0.1/mbmonitor.c
+===================================================================
+--- mb-applet-startup-monitor-0.1.orig/mbmonitor.c
++++ mb-applet-startup-monitor-0.1/mbmonitor.c
+@@ -43,6 +43,9 @@
+ #define POLLTIME 10
+ #define HOURGLASS_N_FRAMES 8
+
++#define FALSE 0
++#define TRUE 1
++
+ typedef struct LaunchList LaunchList;
+
+ struct LaunchList
diff --git a/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk b/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk
new file mode 100644
index 000000000..8f3d7ca44
--- /dev/null
+++ b/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# MatchBox Applet Startup monitor
+#
+#############################################################
+
+MATCHBOX_STARTUP_MONITOR_VERSION = 0.1
+MATCHBOX_STARTUP_MONITOR_SOURCE = mb-applet-startup-monitor-$(MATCHBOX_STARTUP_MONITOR_VERSION).tar.bz2
+MATCHBOX_STARTUP_MONITOR_SITE = http://matchbox-project.org/sources/mb-applet-startup-monitor/$(MATCHBOX_STARTUP_MONITOR_VERSION)
+MATCHBOX_STARTUP_MONITOR_LIBTOOL_PATCH = NO
+MATCHBOX_STARTUP_MONITOR_DEPENDENCIES = matchbox-lib startup-notification
+MATCHBOX_STARTUP_MONITOR_CONF_OPT =
+
+#############################################################
+
+$(eval $(call AUTOTARGETS,package/matchbox,matchbox-startup-monitor))