summaryrefslogtreecommitdiffstats
path: root/package/lua-msgpack-native
diff options
context:
space:
mode:
Diffstat (limited to 'package/lua-msgpack-native')
-rw-r--r--package/lua-msgpack-native/Config.in7
-rw-r--r--package/lua-msgpack-native/lua-msgpack-native.mk29
2 files changed, 36 insertions, 0 deletions
diff --git a/package/lua-msgpack-native/Config.in b/package/lua-msgpack-native/Config.in
new file mode 100644
index 000000000..8894ee535
--- /dev/null
+++ b/package/lua-msgpack-native/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUA_MSGPACK_NATIVE
+ bool "lua-msgpack-native"
+ help
+ This is a native, C language implementation of msgpack
+ (http://msgpack.org) library/protocol for Lua language
+
+ https://github.com/kengonakajima/lua-msgpack-native
diff --git a/package/lua-msgpack-native/lua-msgpack-native.mk b/package/lua-msgpack-native/lua-msgpack-native.mk
new file mode 100644
index 000000000..5d8cd2d8b
--- /dev/null
+++ b/package/lua-msgpack-native/lua-msgpack-native.mk
@@ -0,0 +1,29 @@
+#############################################################
+#
+# lua-msgpack-native
+#
+#############################################################
+LUA_MSGPACK_NATIVE_VERSION = 41cce91ab6
+LUA_MSGPACK_NATIVE_SITE = git://github.com/kengonakajima/lua-msgpack-native.git
+LUA_MSGPACK_NATIVE_METHOD = git
+LUA_MSGPACK_NATIVE_DEPENDENCIES = lua
+LUA_MSGPACK_NATIVE_LICENSE = Apache-2.0
+LUA_MSGPACK_NATIVE_LICENSE_FILES = LICENSE.txt
+
+define LUA_MSGPACK_NATIVE_BUILD_CMDS
+ $(TARGET_CC) $(TARGET_CFLAGS) -fPIC -shared -o $(@D)/msgpack.so $(@D)/mp.c
+endef
+
+define LUA_MSGPACK_NATIVE_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 -D $(@D)/msgpack.so $(TARGET_DIR)/usr/lib/lua/msgpack.so
+endef
+
+define LUA_MSGPACK_NATIVE_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/lib/lua/msgpack.so
+endef
+
+define LUA_MSGPACK_NATIVE_CLEAN_CMDS
+ rm -f $(@D)/msgpack.so
+endef
+
+$(eval $(generic-package))