summaryrefslogtreecommitdiffstats
path: root/package/linphone
diff options
context:
space:
mode:
Diffstat (limited to 'package/linphone')
-rw-r--r--package/linphone/Config.in21
-rw-r--r--package/linphone/linphone.mk12
2 files changed, 33 insertions, 0 deletions
diff --git a/package/linphone/Config.in b/package/linphone/Config.in
new file mode 100644
index 000000000..31c28d8b4
--- /dev/null
+++ b/package/linphone/Config.in
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_LINPHONE
+ bool "linphone"
+ select BR2_PACKAGE_LIBEXOSIP2
+ select BR2_PACKAGE_SPEEX
+ help
+ Linphone is an internet phone or Voice Over IP phone (VoIP).
+
+ With linphone you can communicate freely with people over
+ the internet, with voice, video, and text instant messaging.
+ Linphone makes use of the SIP protocol, an open standard
+ for internet telephony. You can use Linphone with any SIP
+ VoIP operator, including our free SIP audio/video service.
+ linphone is free-software (or open-source), you can download
+ and redistribute it freely.
+ Linphone is available for desktop computers: Linux, Windows,
+ MacOSX, and for mobile phones: Android, iPhone, Blackberry.
+
+ Linphone support in Buildroot is limited to the commandline
+ client, linphonec, and video support is not enabled.
+
+ http://www.linphone.org/
diff --git a/package/linphone/linphone.mk b/package/linphone/linphone.mk
new file mode 100644
index 000000000..6ba6b5333
--- /dev/null
+++ b/package/linphone/linphone.mk
@@ -0,0 +1,12 @@
+#############################################################
+#
+# linphone
+#
+#############################################################
+
+LINPHONE_VERSION = 3.5.2
+LINPHONE_SITE = http://download-mirror.savannah.gnu.org/releases/linphone/3.5.x/sources/
+LINPHONE_CONF_OPT = --disable-video --disable-gtk_ui
+LINPHONE_DEPENDENCIES = libeXosip2 speex
+
+$(eval $(call AUTOTARGETS))