summaryrefslogtreecommitdiffstats
path: root/package/libxml-parser-perl
diff options
context:
space:
mode:
Diffstat (limited to 'package/libxml-parser-perl')
-rw-r--r--package/libxml-parser-perl/libxml-parser-perl.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/libxml-parser-perl/libxml-parser-perl.mk b/package/libxml-parser-perl/libxml-parser-perl.mk
index 9e6f2ecc8..1022302bb 100644
--- a/package/libxml-parser-perl/libxml-parser-perl.mk
+++ b/package/libxml-parser-perl/libxml-parser-perl.mk
@@ -9,9 +9,15 @@ LIBXML_PARSER_PERL_SITE:=http://www.cpan.org/modules/by-module/XML/
LIBXML_PARSER_PERL_DEPENDENCIES = expat
+ifeq ($(BR2_PACKAGE_MICROPERL),y)
+# microperl builds host-microperl, so ensure we build after that to build
+# against host-microperl instead of the system perl
+LIBXML_PARSER_PERL_DEPENDENCIES += microperl
+endif
+
define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
(cd $(@D) ; \
- perl Makefile.PL \
+ $(HOST_CONFIGURE_OPTS) perl Makefile.PL \
PREFIX=$(HOST_DIR)/usr \
EXPATLIBPATH=$(HOST_DIR)/usr/lib \
EXPATINCPATH=$(HOST_DIR)/usr/include \