summaryrefslogtreecommitdiffstats
path: root/package/libxml-parser-perl
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-03-27 17:11:36 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-27 17:28:34 +0200
commitd0e5eb281f0e3b323ecb3446c1b16baf7f3baa69 (patch)
tree91160a184307e6723d61536c4378e18dacc4473b /package/libxml-parser-perl
parent7a70788a2207af8ed97bbd26effaf5e461faf8af (diff)
downloadbuildroot-novena-d0e5eb281f0e3b323ecb3446c1b16baf7f3baa69.tar.gz
buildroot-novena-d0e5eb281f0e3b323ecb3446c1b16baf7f3baa69.zip
libxml-parser-perl: fix host-intltool breakage when microperl is enabled
Microperl will build host-microperl and install it into HOST_DIR/usr/bin, where other packages will pick it up as _CONFIGURE_OPTS / _MAKE_ENV prepends that to the path. libxml-parser-perl didn't though, so it would still be built against the system perl, causing host-intltool to fail when it would use host-microperl together with libxml-parser-perl if the system perl isn't compatible with host-microperl. Fix it by using HOST_CONFIGURE_OPTS and ensuring it is built after (host-)microperl if enabled. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libxml-parser-perl')
-rw-r--r--package/libxml-parser-perl/libxml-parser-perl.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/libxml-parser-perl/libxml-parser-perl.mk b/package/libxml-parser-perl/libxml-parser-perl.mk
index 9e6f2ecc8..1022302bb 100644
--- a/package/libxml-parser-perl/libxml-parser-perl.mk
+++ b/package/libxml-parser-perl/libxml-parser-perl.mk
@@ -9,9 +9,15 @@ LIBXML_PARSER_PERL_SITE:=http://www.cpan.org/modules/by-module/XML/
LIBXML_PARSER_PERL_DEPENDENCIES = expat
+ifeq ($(BR2_PACKAGE_MICROPERL),y)
+# microperl builds host-microperl, so ensure we build after that to build
+# against host-microperl instead of the system perl
+LIBXML_PARSER_PERL_DEPENDENCIES += microperl
+endif
+
define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
(cd $(@D) ; \
- perl Makefile.PL \
+ $(HOST_CONFIGURE_OPTS) perl Makefile.PL \
PREFIX=$(HOST_DIR)/usr \
EXPATLIBPATH=$(HOST_DIR)/usr/lib \
EXPATINCPATH=$(HOST_DIR)/usr/include \