summaryrefslogtreecommitdiffstats
path: root/package/libtheora/libtheora.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/libtheora/libtheora.mk')
-rw-r--r--package/libtheora/libtheora.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/libtheora/libtheora.mk b/package/libtheora/libtheora.mk
new file mode 100644
index 000000000..89489b787
--- /dev/null
+++ b/package/libtheora/libtheora.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# libtheora
+#
+#############################################################
+LIBTHEORA_VERSION = 1.1.1
+LIBTHEORA_SOURCE = libtheora-$(LIBTHEORA_VERSION).tar.bz2
+LIBTHEORA_SITE = http://downloads.xiph.org/releases/theora
+LIBTHEORA_INSTALL_STAGING = YES
+
+LIBTHEORA_CONF_OPT = \
+ --disable-oggtest \
+ --disable-vorbistest \
+ --disable-sdltest \
+ --disable-examples \
+ --disable-spec
+
+LIBTHEORA_DEPENDENCIES = libogg libvorbis host-pkg-config
+
+$(eval $(call AUTOTARGETS))