summaryrefslogtreecommitdiffstats
path: root/package/libsha1
diff options
context:
space:
mode:
Diffstat (limited to 'package/libsha1')
-rw-r--r--package/libsha1/Config.in9
-rw-r--r--package/libsha1/libsha1.mk15
2 files changed, 24 insertions, 0 deletions
diff --git a/package/libsha1/Config.in b/package/libsha1/Config.in
new file mode 100644
index 000000000..5467a6c4c
--- /dev/null
+++ b/package/libsha1/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBSHA1
+ bool "libsha1"
+ help
+ libsha1 is a tiny library providing SHA1 implementation,
+ created for facilitating X server compilation on devices
+ when larger libraries containing SHA1 implementations
+ (OpenSSL, Mozilla NSS) are not needed.
+
+ https://github.com/dottedmag/libsha1
diff --git a/package/libsha1/libsha1.mk b/package/libsha1/libsha1.mk
new file mode 100644
index 000000000..e9658af4b
--- /dev/null
+++ b/package/libsha1/libsha1.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libsha1
+#
+#############################################################
+
+LIBSHA1_VERSION = 0.3
+LIBSHA1_SITE = http://github.com/dottedmag/libsha1/tarball/$(LIBSHA1_VERSION)
+LIBSHA1_INSTALL_STAGING = YES
+
+# We're getting the source code from Github, so there is no generated
+# configure script in the tarball.
+LIBSHA1_AUTORECONF = YES
+
+$(eval $(autotools-package))