summaryrefslogtreecommitdiffstats
path: root/package/libpcap/libpcap.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/libpcap/libpcap.mk')
-rw-r--r--package/libpcap/libpcap.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index 272d646b3..dc72924e9 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -11,8 +11,8 @@ LIBPCAP_INSTALL_STAGING:=YES
# doesn't have an install-strip
LIBPCAP_INSTALL_TARGET_OPT= DESTDIR="$(TARGET_DIR)" \
$(if $(BR2_PREFER_STATIC_LIB),install,install-shared)
-LIBPCAP_INSTALL_STAGING_OPT= DESTDIR="$(STAGING_DIR)" \
- $(if $(BR2_PREFER_STATIC_LIB),install,install-shared)
+LIBPCAP_INSTALL_STAGING_OPT= DESTDIR="$(STAGING_DIR)" install \
+ $(if $(BR2_PREFER_STATIC_LIB),,install-shared)
LIBPCAP_DEPENDENCIES:=zlib
LIBPCAP_CONF_ENV:=ac_cv_linux_vers=$(firstword $(subst .,$(space),$(firstword $(call qstrip,$(BR2_DEFAULT_KERNEL_HEADERS)))))
LIBPCAP_CONF_OPT:=--disable-yydebug --with-pcap=linux