summaryrefslogtreecommitdiffstats
path: root/package/libogg
diff options
context:
space:
mode:
Diffstat (limited to 'package/libogg')
-rw-r--r--package/libogg/Config.in11
-rw-r--r--package/libogg/libogg.mk14
2 files changed, 2 insertions, 23 deletions
diff --git a/package/libogg/Config.in b/package/libogg/Config.in
index bf5f50847..970cc8083 100644
--- a/package/libogg/Config.in
+++ b/package/libogg/Config.in
@@ -3,12 +3,5 @@ config BR2_PACKAGE_LIBOGG
default n
select BR2_PACKAGE_PKGCONFIG
help
- Ogg is the name of Xiph.org's container format for audio, video, and metadata
-
-config BR2_PACKAGE_LIBOGG_HEADERS
- bool "libogg target headers"
- default n
- depends on BR2_PACKAGE_LIBOGG
- help
- Add target headers for the Ogg open source container format
- - Not yet implemented
+ Ogg is the name of Xiph.org's container format for audio,
+ video, and metadata
diff --git a/package/libogg/libogg.mk b/package/libogg/libogg.mk
index 61801a4bd..91deabee5 100644
--- a/package/libogg/libogg.mk
+++ b/package/libogg/libogg.mk
@@ -56,16 +56,6 @@ ifneq ($(strip $(BR2_HAVE_MANPAGES)),y)
rm -rf $(TARGET_DIR)/usr/share/doc/$(LIBOGG_NAME)
endif
-$(TARGET_DIR)/usr/lib/libogg.a: $(STAGING_DIR)/usr/lib/libogg.so
- cp -dpf $(STAGING_DIR)/usr/lib/libogg.a $@
-
-$(TARGET_DIR)/usr/include/ogg/ogg.h: $(STAGING_DIR)/usr/lib/libogg.so
- mkdir -p $(TARGET_DIR)/usr/include/ogg
- cp -dpf $(LIBOGG_DIR)/include/ogg/*.h \
- $(TARGET_DIR)/usr/include/ogg
-
-libogg-header: $(TARGET_DIR)/usr/lib/libogg.a $(TARGET_DIR)/usr/include/ogg/ogg.h
-
libogg: uclibc pkgconfig $(TARGET_DIR)/usr/lib/libogg.so
libogg-source: $(DL_DIR)/$(LIBOGG_SOURCE)
@@ -86,7 +76,3 @@ libogg-dirclean:
ifeq ($(strip $(BR2_PACKAGE_LIBOGG)),y)
TARGETS+=libogg
endif
-
-ifeq ($(strip $(BR2_PACKAGE_LIBOGG_HEADERS)),y)
-TARGETS+=libogg-header
-endif