summaryrefslogtreecommitdiffstats
path: root/package/libhid/libhid.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/libhid/libhid.mk')
-rw-r--r--package/libhid/libhid.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/libhid/libhid.mk b/package/libhid/libhid.mk
new file mode 100644
index 000000000..ec6e5bb62
--- /dev/null
+++ b/package/libhid/libhid.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# libhid
+#
+#############################################################
+
+LIBHID_VERSION = 0.2.16
+LIBHID_SOURCE = libhid-$(LIBHID_VERSION).tar.gz
+LIBHID_SITE = http://alioth.debian.org/frs/download.php/1958
+LIBHID_DEPENDENCIES = libusb-compat libusb
+LIBHID_INSTALL_STAGING = YES
+# configure runs libusb-config for cflags/ldflags. Ensure it picks up
+# the target version
+LIBHID_CONF_ENV = PATH=$(STAGING_DIR)/usr/bin:$(TARGET_PATH)
+LIBHID_CONF_OPT = --disable-swig --without-doxygen --disable-package-config
+
+$(eval $(call AUTOTARGETS,package,libhid))