summaryrefslogtreecommitdiffstats
path: root/package/lcdproc
diff options
context:
space:
mode:
Diffstat (limited to 'package/lcdproc')
-rw-r--r--package/lcdproc/Config.in7
-rw-r--r--package/lcdproc/lcdproc-0.5.5-LCDd.conf.patch18
-rw-r--r--package/lcdproc/lcdproc.mk14
3 files changed, 39 insertions, 0 deletions
diff --git a/package/lcdproc/Config.in b/package/lcdproc/Config.in
new file mode 100644
index 000000000..6c8614d6d
--- /dev/null
+++ b/package/lcdproc/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LCDPROC
+ bool "lcdproc"
+ select BR2_PACKAGE_NCURSES
+ help
+ LCD display driver daemon and clients
+
+ http://lcdproc.org/
diff --git a/package/lcdproc/lcdproc-0.5.5-LCDd.conf.patch b/package/lcdproc/lcdproc-0.5.5-LCDd.conf.patch
new file mode 100644
index 000000000..283ac8867
--- /dev/null
+++ b/package/lcdproc/lcdproc-0.5.5-LCDd.conf.patch
@@ -0,0 +1,18 @@
+Fix the default LCDd configuration file, so that the DriverPath
+is set to the correct lcdproc library install path, rather than
+the dummy/default path.
+
+Signed-off-by: Simon Dawson <spdawson at gmail.com>
+---
+
+--- lcdproc-0.5.3/LCDd.conf.orig 2009-06-20 14:48:34.000000000 +0100
++++ lcdproc-0.5.3/LCDd.conf 2010-05-11 10:02:21.000000000 +0100
+@@ -34,7 +34,7 @@
+ # the driver modules and will thus not be able to
+ # function properly.
+ # NOTE: Always place a slash as last character !
+-DriverPath=server/drivers/
++DriverPath=/usr/lib/lcdproc/
+
+ # Tells the server to load the given drivers. Multiple lines can be given.
+ # The name of the driver is case sensitive and determines the section
diff --git a/package/lcdproc/lcdproc.mk b/package/lcdproc/lcdproc.mk
new file mode 100644
index 000000000..e8919e9c8
--- /dev/null
+++ b/package/lcdproc/lcdproc.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# lcdproc
+#
+#############################################################
+LCDPROC_VERSION = 0.5.5
+LCDPROC_SOURCE = lcdproc-$(LCDPROC_VERSION).tar.gz
+LCDPROC_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/project/lcdproc/lcdproc/$(LCDPROC_VERSION)
+
+LCDPROC_CONF_OPT = --enable-drivers=all
+
+LCDPROC_DEPENDENCIES = ncurses
+
+$(eval $(call AUTOTARGETS))