summaryrefslogtreecommitdiffstats
path: root/package/kexec
diff options
context:
space:
mode:
Diffstat (limited to 'package/kexec')
-rw-r--r--package/kexec/kexec.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/kexec/kexec.mk b/package/kexec/kexec.mk
index 436788517..5081ee81a 100644
--- a/package/kexec/kexec.mk
+++ b/package/kexec/kexec.mk
@@ -16,12 +16,10 @@ else
KEXEC_CONF_OPT += --without-zlib
endif
-$(eval $(call AUTOTARGETS,package,kexec))
-
-$(KEXEC_HOOK_POST_INSTALL): $(KEXEC_TARGET_INSTALL_TARGET)
-ifneq ($(BR2_ENABLE_DEBUG),y)
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/sbin/kexec
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/sbin/kdump
-endif
+define KEXEC_REMOVE_LIB_TOOLS
rm -rf $(TARGET_DIR)/usr/lib/kexec-tools
- touch $@
+endef
+
+KEXEC_POST_INSTALL_TARGET_HOOKS += KEXEC_REMOVE_LIB_TOOLS
+
+$(eval $(call AUTOTARGETS,package,kexec))