summaryrefslogtreecommitdiffstats
path: root/package/kexec/kexec.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kexec/kexec.mk')
-rw-r--r--package/kexec/kexec.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kexec/kexec.mk b/package/kexec/kexec.mk
index f9582a5df..e24c3e1ac 100644
--- a/package/kexec/kexec.mk
+++ b/package/kexec/kexec.mk
@@ -33,11 +33,11 @@ kexec-source: $(DL_DIR)/$(KEXEC_SOURCE) $(DL_DIR)/$(KEXEC_PATCH)
$(KEXEC_DIR)/.unpacked: $(DL_DIR)/$(KEXEC_SOURCE) $(DL_DIR)/$(KEXEC_PATCH)
$(KEXEC_CAT) $(DL_DIR)/$(KEXEC_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.patch
ifneq ($(KEXEC_PATCH),)
(cd $(KEXEC_DIR) && $(KEXEC_CAT) $(DL_DIR)/$(KEXEC_PATCH) | patch -p1)
toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
endif
+ toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.dpatch
touch $(KEXEC_DIR)/.unpacked
$(KEXEC_DIR)/.configured: $(KEXEC_DIR)/.unpacked