summaryrefslogtreecommitdiffstats
path: root/package/kexec/kexec.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kexec/kexec.mk')
-rw-r--r--package/kexec/kexec.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kexec/kexec.mk b/package/kexec/kexec.mk
index d83802d46..9bc0c55a6 100644
--- a/package/kexec/kexec.mk
+++ b/package/kexec/kexec.mk
@@ -38,7 +38,6 @@ ifneq ($(KEXEC_PATCH),)
(cd $(KEXEC_DIR) && $(KEXEC_CAT) $(DL_DIR)/$(KEXEC_PATCH) | patch -p1)
toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
endif
-
touch $(KEXEC_DIR)/.unpacked
$(KEXEC_DIR)/.configured: $(KEXEC_DIR)/.unpacked
@@ -61,7 +60,7 @@ $(TARGET_DIR)/$(KEXEC_TARGET_BINARY): $(KEXEC_DIR)/$(KEXEC_BINARY)
$(KEXEC_DIR)/objdir-$(GNU_TARGET_NAME)/build/sbin/kdump \
$(TARGET_DIR)/sbin/
-kexec: uclibc host-fakeroot $(TARGET_DIR)/$(KEXEC_TARGET_BINARY)
+kexec: uclibc $(TARGET_DIR)/$(KEXEC_TARGET_BINARY)
kexec-clean:
-$(MAKE) -C $(KEXEC_DIR) clean