summaryrefslogtreecommitdiffstats
path: root/package/ipsec-tools/ipsec-tools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ipsec-tools/ipsec-tools.mk')
-rw-r--r--package/ipsec-tools/ipsec-tools.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/ipsec-tools/ipsec-tools.mk b/package/ipsec-tools/ipsec-tools.mk
index d6b9c7bbe..52e53f25a 100644
--- a/package/ipsec-tools/ipsec-tools.mk
+++ b/package/ipsec-tools/ipsec-tools.mk
@@ -42,18 +42,16 @@ else
IPSEC_TOOLS_CONFIG_FLAGS+= --disable-stats
endif
-# At first check, if uClibc supports IPv6
-ifeq ($(shell grep -qs '__UCLIBC_HAS_IPV6__ 1' \
- $(STAGING_DIR)/include/bits/uClibc_config.h && echo IPV6), IPV6)
+ifeq ($(BR2_INET_IPV6),y)
ifeq ($(strip $(BR2_PACKAGE_IPSEC_TOOLS_IPV6)), y)
IPSEC_TOOLS_CONFIG_FLAGS+= --enable-ipv6
else
-IPSEC_TOOLS_CONFIG_FLAGS+= --disable-ipv6
+IPSEC_TOOLS_CONFIG_FLAGS+= $(DISABLE_IPV6)
endif
else # ignore user's choice if it doesn't
-IPSEC_TOOLS_CONFIG_FLAGS+= --disable-ipv6
+IPSEC_TOOLS_CONFIG_FLAGS+= $(DISABLE_IPV6)
endif
ifneq ($(strip $(BR2_PACKAGE_IPSEC_TOOLS_READLINE)), y)