summaryrefslogtreecommitdiffstats
path: root/package/igh-ethercat/igh-ethercat.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/igh-ethercat/igh-ethercat.mk')
-rw-r--r--package/igh-ethercat/igh-ethercat.mk20
1 files changed, 4 insertions, 16 deletions
diff --git a/package/igh-ethercat/igh-ethercat.mk b/package/igh-ethercat/igh-ethercat.mk
index b6ac5b824..f04eb57f3 100644
--- a/package/igh-ethercat/igh-ethercat.mk
+++ b/package/igh-ethercat/igh-ethercat.mk
@@ -1,8 +1,7 @@
-IGH_ETHERCAT_VERSION = stable-1.5
-IGH_ETHERCAT_SITE = http://etherlabmaster.hg.sourceforge.net/hgweb/etherlabmaster/etherlabmaster/archive/
-IGH_ETHERCAT_SOURCE = $(IGH_ETHERCAT_VERSION).tar.bz2
+IGH_ETHERCAT_VERSION = 1.5.1
+IGH_ETHERCAT_SITE = http://etherlab.org/download/ethercat/
+IGH_ETHERCAT_SOURCE = ethercat-$(IGH_ETHERCAT_VERSION).tar.bz2
-IGH_ETHERCAT_AUTORECONF = YES
IGH_ETHERCAT_DEPENDENCIES = linux
IGH_ETHERCAT_INSTALL_STAGING = YES
@@ -12,20 +11,9 @@ IGH_ETHERCAT_CONF_OPT = \
IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_8139TOO),--enable-8139too,--disable-8139too)
IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E100),--enable-e100,--disable-e100)
IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000),--enable-e1000,--disable-e1000)
+IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000E),--enable-e1000e,--disable-e1000e)
IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_R8169),--enable-r8169,--disable-r8169)
-# Since we download ethercat from source control, we have to emulate
-# the bootstrap script that creates the ChangeLog file before running
-# autoreconf. We don't want to run that script directly, since we
-# leave to the autotargets infrastructure the responsability of
-# running 'autoreconf' so that the dependencies on host-automake,
-# host-autoconf and al. are correct.
-define IGH_ETHERCAT_CREATE_CHANGELOG
- touch $(@D)/ChangeLog
-endef
-
-IGH_ETHERCAT_POST_PATCH_HOOKS += IGH_ETHERCAT_CREATE_CHANGELOG
-
define IGH_ETHERCAT_BUILD_MODULES
$(MAKE) -C $(@D) $(LINUX_MAKE_FLAGS) modules
endef