summaryrefslogtreecommitdiffstats
path: root/package/hiawatha/hiawatha-support-for-external-polarssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/hiawatha/hiawatha-support-for-external-polarssl.patch')
-rw-r--r--package/hiawatha/hiawatha-support-for-external-polarssl.patch27
1 files changed, 14 insertions, 13 deletions
diff --git a/package/hiawatha/hiawatha-support-for-external-polarssl.patch b/package/hiawatha/hiawatha-support-for-external-polarssl.patch
index e6033b9da..edc774b7d 100644
--- a/package/hiawatha/hiawatha-support-for-external-polarssl.patch
+++ b/package/hiawatha/hiawatha-support-for-external-polarssl.patch
@@ -9,21 +9,22 @@ This patch adds a ENABLE_SSL_EXTERNAL option, which, when used in
addition to ENABLE_SSL, tells Hiawatha's build system to link against
the already existing PolarSSL library instead of building its own.
+[Gustavo]: Update for version 8.3
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-Index: hiawatha-8.1/CMakeLists.txt
-===================================================================
---- hiawatha-8.1.orig/CMakeLists.txt
-+++ hiawatha-8.1/CMakeLists.txt
-@@ -9,6 +9,7 @@
- option(ENABLE_IPV6 "Enable IPv6 support in Hiawatha." ON)
- option(ENABLE_MONITOR "Enable support for the Hiawatha Monitor." OFF)
- option(ENABLE_SSL "Enable SSL (PolarSSL) support in Hiawatha." ON)
-+option(ENABLE_SSL_EXTERNAL "Enable SSL (PolarSSL) as an external library." OFF)
- option(ENABLE_TOOLKIT "Enable the URL toolkit in Hiawatha" ON)
- option(ENABLE_XSLT "Enable XSLT support in Hiawatha." ON)
+diff -Nura hiawatha-8.3.orig//CMakeLists.txt hiawatha-8.3/CMakeLists.txt
+--- hiawatha-8.3.orig//CMakeLists.txt 2012-05-23 14:22:26.000000000 -0300
++++ hiawatha-8.3/CMakeLists.txt 2012-05-24 08:13:00.007107500 -0300
+@@ -10,6 +10,7 @@
+ option(ENABLE_MONITOR "Enable support for the Hiawatha Monitor." off)
+ option(ENABLE_RPROXY "Enable reverse proxy support in Hiawatha." on)
+ option(ENABLE_SSL "Enable SSL (PolarSSL) support in Hiawatha." on)
++option(ENABLE_SSL_EXTERNAL "Enable SSL (PolarSSL) as an external library." off)
+ option(ENABLE_TOOLKIT "Enable the URL toolkit in Hiawatha" on)
+ option(ENABLE_XSLT "Enable XSLT support in Hiawatha." on)
-@@ -86,19 +87,23 @@
+@@ -85,19 +86,23 @@
# PolarSSL
if(ENABLE_SSL)
@@ -48,7 +49,7 @@ Index: hiawatha-8.1/CMakeLists.txt
# Configure files
configure_file(config.h.in config.h)
foreach (configfile ${config_files_in})
-@@ -119,7 +124,9 @@
+@@ -118,7 +123,9 @@
target_link_libraries(hiawatha ${CRYPT_LIBRARY} pthread ${Z_LIBRARY})
if(ENABLE_SSL)
target_link_libraries(hiawatha ${POLARSSL_LIBRARY})