summaryrefslogtreecommitdiffstats
path: root/package/gvfs
diff options
context:
space:
mode:
Diffstat (limited to 'package/gvfs')
-rw-r--r--package/gvfs/gvfs.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/gvfs/gvfs.mk b/package/gvfs/gvfs.mk
index d99c7843e..6e88f6eea 100644
--- a/package/gvfs/gvfs.mk
+++ b/package/gvfs/gvfs.mk
@@ -12,6 +12,10 @@ GVFS_SITE = http://ftp.gnome.org/pub/GNOME/sources/gvfs/$(GVFS_VERSION_MAJOR)
GVFS_INSTALL_STAGING = YES
GVFS_DEPENDENCIES = host-pkgconf host-libglib2 libglib2 dbus shared-mime-info
+# Export ac_cv_path_LIBGCRYPT_CONFIG unconditionally to prevent
+# build system from searching the host paths.
+GVFS_CONF_ENV = ac_cv_path_LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
+
GVFS_CONF_OPT = \
--disable-gconf \
--disable-cdda \
@@ -42,6 +46,10 @@ else
GVFS_CONF_OPT += --disable-fuse
endif
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+GVFS_DEPENDENCIES += libgcrypt
+endif
+
ifeq ($(BR2_PACKAGE_LIBSOUP),y)
GVFS_DEPENDENCIES += libsoup
GVFS_CONF_OPT += --enable-http