summaryrefslogtreecommitdiffstats
path: root/package/gvfs/gvfs.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/gvfs/gvfs.mk')
-rw-r--r--package/gvfs/gvfs.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/gvfs/gvfs.mk b/package/gvfs/gvfs.mk
index 64e6df476..7638f541a 100644
--- a/package/gvfs/gvfs.mk
+++ b/package/gvfs/gvfs.mk
@@ -69,12 +69,10 @@ else
GVFS_CONF_OPT += --disable-samba
endif
-$(eval $(call AUTOTARGETS,package,gvfs))
-
-$(GVFS_HOOK_POST_INSTALL): $(GVFS_TARGET_INSTALL_TARGET)
+define GVFS_REMOVE_USELESS_BINARY
rm $(TARGET_DIR)/usr/bin/gvfs-less
-ifneq ($(BR2_ENABLE_DEBUG),y)
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/bin/gvfs*
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/libexec/gvfs*
-endif
- touch $@
+endef
+
+GVFS_POST_INSTALL_TARGET_HOOKS += GVFS_REMOVE_USELESS_BINARY
+
+$(eval $(call AUTOTARGETS,package,gvfs))