summaryrefslogtreecommitdiffstats
path: root/package/grep/grep.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/grep/grep.mk')
-rw-r--r--package/grep/grep.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index ed019b211..c12b1df1c 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -23,7 +23,7 @@ $(GNUGREP_DIR)/.unpacked: $(DL_DIR)/$(GNUGREP_SOURCE)
$(GNUGREP_CAT) $(GNUGREP_DIR).xxx/grep_$(GNUGREP_VERSION).tar.gz | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
rm -rf $(GNUGREP_DIR).xxx
$(CONFIG_UPDATE) $(GNUGREP_DIR)
- touch $(GNUGREP_DIR)/.unpacked
+ touch $@
$(GNUGREP_DIR)/.configured: $(GNUGREP_DIR)/.unpacked
(cd $(GNUGREP_DIR); rm -rf config.cache; \
@@ -49,7 +49,7 @@ $(GNUGREP_DIR)/.configured: $(GNUGREP_DIR)/.unpacked
--disable-perl-regexp \
--without-included-regex \
)
- touch $(GNUGREP_DIR)/.configured
+ touch $@
$(GNUGREP_DIR)/$(GNUGREP_BINARY): $(GNUGREP_DIR)/.configured
$(MAKE) -C $(GNUGREP_DIR)