summaryrefslogtreecommitdiffstats
path: root/package/gpsd/gpsd.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/gpsd/gpsd.mk')
-rw-r--r--package/gpsd/gpsd.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/gpsd/gpsd.mk b/package/gpsd/gpsd.mk
index ab7e921c1..6c249911b 100644
--- a/package/gpsd/gpsd.mk
+++ b/package/gpsd/gpsd.mk
@@ -18,6 +18,15 @@ else
GPSD_CONF_OPT += --disable-libgpsmm
endif
+# Enable or disable Qt binding
+ifeq ($(BR2_PACKAGE_QT_NETWORK),y)
+ GPSD_CONF_ENV += QMAKE="$(QT_QMAKE)"
+ GPSD_CONF_OPT += --enable-libQgpsmm
+ GPSD_DEPENDENCIES += qt
+else
+ GPSD_CONF_OPT += --disable-libQgpsmm
+endif
+
# If libusb is available build it before so the package can use it
ifeq ($(BR2_PACKAGE_LIBUSB),y)
GPSD_DEPENDENCIES += libusb