summaryrefslogtreecommitdiffstats
path: root/package/gawk/gawk-01-no-versioned.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/gawk/gawk-01-no-versioned.patch')
-rw-r--r--package/gawk/gawk-01-no-versioned.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/gawk/gawk-01-no-versioned.patch b/package/gawk/gawk-01-no-versioned.patch
new file mode 100644
index 000000000..ff28581ea
--- /dev/null
+++ b/package/gawk/gawk-01-no-versioned.patch
@@ -0,0 +1,26 @@
+Disabled versioned installation of binaries to save space.
+Also use symlinks where it's appropiate.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+---
+
+diff -Nura gawk-4.0.0.orig/Makefile.in gawk-4.0.0/Makefile.in
+--- gawk-4.0.0.orig/Makefile.in 2011-06-24 05:16:13.000000000 -0300
++++ gawk-4.0.0/Makefile.in 2011-11-11 15:31:16.429577288 -0300
+@@ -403,7 +403,7 @@
+ MAINTAINERCLEANFILES = version.c
+
+ # We want hard links for install-exec-hook, below
+-LN = ln
++LN = $(LN_S)
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+
+@@ -1011,6 +1011,7 @@
+ # (This is done universally, which may not always be right, but
+ # there's no easy way to distinguish GNU from non-GNU systems.)
+ install-exec-hook:
++foo:
+ (cd $(DESTDIR)$(bindir); \
+ $(LN) gawk$(EXEEXT) gawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \
+ $(LN) pgawk$(EXEEXT) pgawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \