summaryrefslogtreecommitdiffstats
path: root/package/gamin/gamin.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/gamin/gamin.mk')
-rw-r--r--package/gamin/gamin.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/gamin/gamin.mk b/package/gamin/gamin.mk
index 90b215a91..1aa5f8be0 100644
--- a/package/gamin/gamin.mk
+++ b/package/gamin/gamin.mk
@@ -12,9 +12,8 @@ GAMIN_INSTALL_TARGET = YES
GAMIN_CONF_OPT = --program-prefix="" --disable-debug
-ifneq ($(BR2_PACKAGE_PYTHON),y)
+# python support broken
GAMIN_CONF_OPT += --without-python
-endif
GAMIN_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
@@ -22,6 +21,8 @@ GAMIN_CONF_ENV = have_abstract_sockets=no
ifneq ($(BR2_LARGEFILE),y)
GAMIN_CONF_ENV += CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
+# the above doesn't work with shared config.cache
+GAMIN_USE_CONFIG_CACHE = NO
endif
GAMIN_DEPENDENCIES = libglib2