summaryrefslogtreecommitdiffstats
path: root/package/games/gnuchess/gnuchess.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/games/gnuchess/gnuchess.mk')
-rw-r--r--package/games/gnuchess/gnuchess.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/games/gnuchess/gnuchess.mk b/package/games/gnuchess/gnuchess.mk
new file mode 100644
index 000000000..b1ff3b73a
--- /dev/null
+++ b/package/games/gnuchess/gnuchess.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# gnuchess
+#
+#############################################################
+GNUCHESS_VERSION = 5.07
+GNUCHESS_SOURCE = gnuchess-$(GNUCHESS_VERSION).tar.gz
+GNUCHESS_SITE = $(BR2_GNU_MIRROR)/chess
+GNUCHESS_INSTALL_STAGING = NO
+GNUCHESS_INSTALL_TARGET = YES
+
+GNUCHESS_CONF_ENV = ac_cv_func_realloc_0_nonnull=yes ac_cv_func_malloc_0_nonnull=yes
+
+GNUCHESS_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package/games,gnuchess))
+