summaryrefslogtreecommitdiffstats
path: root/package/fmtools
diff options
context:
space:
mode:
Diffstat (limited to 'package/fmtools')
-rw-r--r--package/fmtools/Config.in9
-rw-r--r--package/fmtools/fmtools.mk19
2 files changed, 28 insertions, 0 deletions
diff --git a/package/fmtools/Config.in b/package/fmtools/Config.in
new file mode 100644
index 000000000..159161889
--- /dev/null
+++ b/package/fmtools/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_FMTOOLS
+ bool "fmtools"
+ help
+ fmtools is a pair of simple command-line utilities for
+ "video4linux" radio tuner cards under Linux. It includes
+ fm for power control, tuning, and volume and fmscan for
+ scanning for stations.
+
+ http://www.stanford.edu/~blp/fmtools/
diff --git a/package/fmtools/fmtools.mk b/package/fmtools/fmtools.mk
new file mode 100644
index 000000000..f705173ec
--- /dev/null
+++ b/package/fmtools/fmtools.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# fmtools
+#
+#############################################################
+
+FMTOOLS_VERSION = 1.0.2
+FMTOOLS_SITE = http://www.stanford.edu/~blp/fmtools/
+
+define FMTOOLS_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define FMTOOLS_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/fm $(TARGET_DIR)/usr/sbin/fm
+ $(INSTALL) -D -m 0755 $(@D)/fmscan $(TARGET_DIR)/usr/sbin/fmscan
+endef
+
+$(eval $(call GENTARGETS))