summaryrefslogtreecommitdiffstats
path: root/package/flashbench
diff options
context:
space:
mode:
Diffstat (limited to 'package/flashbench')
-rw-r--r--package/flashbench/Config.in14
-rw-r--r--package/flashbench/flashbench.mk22
2 files changed, 36 insertions, 0 deletions
diff --git a/package/flashbench/Config.in b/package/flashbench/Config.in
new file mode 100644
index 000000000..39cdb1dad
--- /dev/null
+++ b/package/flashbench/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_FLASHBENCH
+ bool "flashbench"
+ depends on BR2_LARGEFILE
+ help
+ Flashbench - Identify characteristics of flash media.
+
+ This is the tool used to identify the properties of
+ SD cards and other media for the Linaro flash memory
+ survey.
+
+ https://wiki.linaro.org/WorkingGroups/KernelConsolidation/Projects/FlashCardSurvey
+
+comment "flashbench requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/flashbench/flashbench.mk b/package/flashbench/flashbench.mk
new file mode 100644
index 000000000..ead1346f7
--- /dev/null
+++ b/package/flashbench/flashbench.mk
@@ -0,0 +1,22 @@
+#############################################################
+#
+# flashbench
+#
+#############################################################
+
+FLASHBENCH_VERSION = 2e30b1968a66147412f21002ea844122a0d5e2f0
+FLASHBENCH_SITE = git://git.linaro.org/people/arnd/flashbench.git
+FLASHBENCH_LICENSE = GPLv2
+FLASHBENCH_LICENSE_FILES = COPYING
+
+define FLASHBENCH_BUILD_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+ LDFLAGS="$(TARGET_LDFLAGS) -lrt"
+endef
+
+define FLASHBENCH_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 -D $(@D)/flashbench $(TARGET_DIR)/usr/bin/flashbench
+ $(INSTALL) -m 755 -D $(@D)/erase $(TARGET_DIR)/usr/bin/erase
+endef
+
+$(eval $(generic-package))