summaryrefslogtreecommitdiffstats
path: root/package/fbgrab/fbgrab-proper_makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/fbgrab/fbgrab-proper_makefile.patch')
-rw-r--r--package/fbgrab/fbgrab-proper_makefile.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/fbgrab/fbgrab-proper_makefile.patch b/package/fbgrab/fbgrab-proper_makefile.patch
new file mode 100644
index 000000000..e907ed7d8
--- /dev/null
+++ b/package/fbgrab/fbgrab-proper_makefile.patch
@@ -0,0 +1,23 @@
+[PATCH] fbgrab: A proper Makefile for cross compiling
+
+Respect to the CC, CFLAGS and LDFLAGS is required for cross compiling in
+Buildroot. And there's no need to run the source through splint.
+
+Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
+
+--- fbgrab-1.0.orig/Makefile 2010-12-07 22:57:24.000000000 +0100
++++ fbgrab-1.0/Makefile 2010-12-07 22:58:36.000000000 +0100
+@@ -3,9 +3,10 @@
+ ### modular. So this is a simple gnu Makefile...
+ ###
+
+-fbgrab: fbgrab.c
+- splint +posixlib fbgrab.c
+- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
++LDFLAGS += -lpng -lz
++
++fbgrab: fbgrab.o
++ $(CC) $(LDFLAGS) fbgrab.o -o $@
+
+ install:
+ strip fbgrab