summaryrefslogtreecommitdiffstats
path: root/package/fbdump
diff options
context:
space:
mode:
Diffstat (limited to 'package/fbdump')
-rw-r--r--package/fbdump/fbdump.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/fbdump/fbdump.mk b/package/fbdump/fbdump.mk
index 3ca10bf1e..820ae9682 100644
--- a/package/fbdump/fbdump.mk
+++ b/package/fbdump/fbdump.mk
@@ -9,4 +9,13 @@ FBDUMP_SITE:=http://www.rcdrummond.net/fbdump
FBDUMP_LICENSE = GPLv2
FBDUMP_LICENSE_FILES = COPYING
+# The VGA16 specific feature of fbdump doesn't make much sense outside
+# of the x86/x86-64 architectures, and causes build problems on some
+# architectures as outw() is not always available.
+ifeq ($(BR2_i386)$(BR2_x86_64),y)
+FBDUMP_CONF_OPT += --enable-vga16fb
+else
+FBDUMP_CONF_OPT += --disable-vga16fb
+endif
+
$(eval $(autotools-package))