summaryrefslogtreecommitdiffstats
path: root/package/fbdump
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-09-18 10:03:33 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-20 14:49:57 +0200
commit9f996396d5ec8e6de6882695de970f24cfcfe59d (patch)
treebcd2d411cf1a5799222992761e9d34ae751286e1 /package/fbdump
parentfee31757683e39dba28527215e9e7fa6150c52cd (diff)
downloadbuildroot-novena-9f996396d5ec8e6de6882695de970f24cfcfe59d.tar.gz
buildroot-novena-9f996396d5ec8e6de6882695de970f24cfcfe59d.zip
fbdump: only build VGA16 support on x86/x86-64
The VGA16 dumping feature probably doesn't make much sense on anything else than x86 and x86-64, as it is accessing I/O ports that seem PC-specific. Moreover, some architectures such as SH4, do not have an implementation of outw() in uClibc, but we quite certainly don't care about VGA16 support for such architectures. Fixes: http://autobuild.buildroot.org/results/e1c860830dd585830cf5ca5f935b81856e992334/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/fbdump')
-rw-r--r--package/fbdump/fbdump.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/fbdump/fbdump.mk b/package/fbdump/fbdump.mk
index 3ca10bf1e..820ae9682 100644
--- a/package/fbdump/fbdump.mk
+++ b/package/fbdump/fbdump.mk
@@ -9,4 +9,13 @@ FBDUMP_SITE:=http://www.rcdrummond.net/fbdump
FBDUMP_LICENSE = GPLv2
FBDUMP_LICENSE_FILES = COPYING
+# The VGA16 specific feature of fbdump doesn't make much sense outside
+# of the x86/x86-64 architectures, and causes build problems on some
+# architectures as outw() is not always available.
+ifeq ($(BR2_i386)$(BR2_x86_64),y)
+FBDUMP_CONF_OPT += --enable-vga16fb
+else
+FBDUMP_CONF_OPT += --disable-vga16fb
+endif
+
$(eval $(autotools-package))