summaryrefslogtreecommitdiffstats
path: root/package/f2fs-tools
diff options
context:
space:
mode:
Diffstat (limited to 'package/f2fs-tools')
-rw-r--r--package/f2fs-tools/Config.in12
-rw-r--r--package/f2fs-tools/f2fs-tools.mk17
2 files changed, 29 insertions, 0 deletions
diff --git a/package/f2fs-tools/Config.in b/package/f2fs-tools/Config.in
new file mode 100644
index 000000000..20db9283a
--- /dev/null
+++ b/package/f2fs-tools/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_F2FS_TOOLS
+ bool "f2fs-tools"
+ select BR2_PACKAGE_UTIL_LINUX
+ depends on BR2_LARGEFILE
+ depends on BR2_USE_WCHAR # util-linux
+ help
+ Tools for Flash-Friendly File System (F2FS)
+
+ http://sourceforge.net/projects/f2fs-tools/
+
+comment "f2fs-tools requires a toolchain with LARGEFILE and WCHAR support"
+ depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
diff --git a/package/f2fs-tools/f2fs-tools.mk b/package/f2fs-tools/f2fs-tools.mk
new file mode 100644
index 000000000..f217bf426
--- /dev/null
+++ b/package/f2fs-tools/f2fs-tools.mk
@@ -0,0 +1,17 @@
+#############################################################
+#
+# f2fs-tools
+#
+#############################################################
+
+F2FS_TOOLS_VERSION = e3eadd686ed1da1828f32977a36b694bc0090f4e
+F2FS_TOOLS_SITE = http://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git
+F2FS_TOOLS_SITE_METHOD = git
+F2FS_TOOLS_CONF_ENV = ac_cv_file__git=no
+F2FS_TOOLS_DEPENDENCIES = host-pkgconf util-linux
+# GIT version, shipped without configure
+F2FS_TOOLS_AUTORECONF = YES
+F2FS_LICENSE = GPLv2
+F2FS_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))