summaryrefslogtreecommitdiffstats
path: root/package/efl
diff options
context:
space:
mode:
Diffstat (limited to 'package/efl')
-rw-r--r--package/efl/libevas/libevas.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/efl/libevas/libevas.mk b/package/efl/libevas/libevas.mk
index 098afe3f9..0a908424f 100644
--- a/package/efl/libevas/libevas.mk
+++ b/package/efl/libevas/libevas.mk
@@ -203,5 +203,13 @@ else
LIBEVAS_CONF_OPT += --disable-font-loader-eet
endif
+# libevas installs the source code of examples on the target, which
+# are generally not useful.
+define LIBEVAS_REMOVE_EXAMPLES
+ rm -rf $(TARGET_DIR)/usr/share/evas/examples/
+endef
+
+LIBEVAS_POST_INSTALL_TARGET_HOOKS += LIBEVAS_REMOVE_EXAMPLES
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))