summaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Config.in14
-rw-r--r--package/dropbear/dropbear.mk8
2 files changed, 22 insertions, 0 deletions
diff --git a/package/dropbear/Config.in b/package/dropbear/Config.in
index c30228f20..0903ad160 100644
--- a/package/dropbear/Config.in
+++ b/package/dropbear/Config.in
@@ -23,3 +23,17 @@ config BR2_PACKAGE_DROPBEAR_SMALL
Tradeoffs are slower hashes and ciphers, and disabling of the
blowfish cipher and zlib.
+
+config BR2_PACKAGE_DROPBEAR_WTMP
+ bool "log dropbear access to wtmp"
+ depends on BR2_PACKAGE_DROPBEAR
+ help
+ Enable logging of dropbear access to wtmp. Notice that
+ Buildroot does not generate wtmp by default.
+
+config BR2_PACKAGE_DROPBEAR_LASTLOG
+ bool "log dropbear access to lastlog"
+ depends on BR2_PACKAGE_DROPBEAR
+ help
+ Enable logging of dropbear access to lastlog. Notice that
+ Buildroot does not generate lastlog by default.
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index e9da42df0..bced0ef4e 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -46,6 +46,14 @@ DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_BUILD_FEATURED
DROPBEAR_DEPENDENCIES += zlib
endif
+ifneq ($(BR2_PACKAGE_DROPBEAR_WTMP),y)
+DROPBEAR_CONF_OPT += --disable-wtmp
+endif
+
+ifneq ($(BR2_PACKAGE_DROPBEAR_LASTLOG),y)
+DROPBEAR_CONF_OPT += --disable-lastlog
+endif
+
define DROPBEAR_INSTALL_TARGET_CMDS
$(INSTALL) -m 755 $(@D)/dropbearmulti $(TARGET_DIR)/usr/sbin/dropbear
for f in $(DROPBEAR_TARGET_BINS); do \