summaryrefslogtreecommitdiffstats
path: root/package/dosfstools/dosfstools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/dosfstools/dosfstools.mk')
-rw-r--r--package/dosfstools/dosfstools.mk23
1 files changed, 12 insertions, 11 deletions
diff --git a/package/dosfstools/dosfstools.mk b/package/dosfstools/dosfstools.mk
index 7482bc870..4664faa6c 100644
--- a/package/dosfstools/dosfstools.mk
+++ b/package/dosfstools/dosfstools.mk
@@ -4,7 +4,7 @@
#
################################################################################
-DOSFSTOOLS_VERSION = 3.0.16
+DOSFSTOOLS_VERSION = 3.0.18
DOSFSTOOLS_SITE = http://daniel-baumann.ch/files/software/dosfstools
DOSFSTOOLS_LICENSE = GPLv3+
DOSFSTOOLS_LICENSE_FILES = COPYING
@@ -18,28 +18,29 @@ DOSFSTOOLS_DEPENDENCIES += libiconv
DOSFSTOOLS_LDFLAGS += -liconv
endif
-MKDOSFS_BINARY = mkdosfs
-DOSFSCK_BINARY = dosfsck
-DOSFSLABEL_BINARY = dosfslabel
+FATLABEL_BINARY = fatlabel
+FSCK_FAT_BINARY = fsck.fat
+MKFS_FAT_BINARY = mkfs.fat
define DOSFSTOOLS_BUILD_CMDS
$(MAKE) CFLAGS="$(TARGET_CFLAGS)" CC="$(TARGET_CC)" \
LDFLAGS="$(DOSFSTOOLS_LDFLAGS)" -C $(@D)
endef
-DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_MKDOSFS)+=$(MKDOSFS_BINARY)
-DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_DOSFSCK)+=$(DOSFSCK_BINARY)
-DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_DOSFSLABEL)+=$(DOSFSLABEL_BINARY)
+DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_FATLABEL)+=$(FATLABEL_BINARY)
+DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_FSCK_FAT)+=$(FSCK_FAT_BINARY)
+DOSFSTOOLS_INSTALL_BIN_FILES_$(BR2_PACKAGE_DOSFSTOOLS_MKFS_FAT)+=$(MKFS_FAT_BINARY)
define DOSFSTOOLS_INSTALL_TARGET_CMDS
test -z "$(DOSFSTOOLS_INSTALL_BIN_FILES_y)" || \
- install -m 755 $(addprefix $(@D)/,$(DOSFSTOOLS_INSTALL_BIN_FILES_y)) $(TARGET_DIR)/sbin/
+ $(INSTALL) -m 755 $(addprefix $(@D)/,$(DOSFSTOOLS_INSTALL_BIN_FILES_y)) \
+ $(TARGET_DIR)/sbin/
endef
define DOSFSTOOLS_UNINSTALL_TARGET_CMDS
- rm -f $(TARGET_DIR)/sbin/$(MKDOSFS_BINARY)
- rm -f $(TARGET_DIR)/sbin/$(DOSFSCK_BINARY)
- rm -f $(TARGET_DIR)/sbin/$(DOSFSLABEL_BINARY)
+ rm -f $(TARGET_DIR)/sbin/$(FATLABEL_BINARY)
+ rm -f $(TARGET_DIR)/sbin/$(FSCK_FAT_BINARY)
+ rm -f $(TARGET_DIR)/sbin/$(MKFS_FAT_BINARY)
endef
define DOSFSTOOLS_CLEAN_CMDS