summaryrefslogtreecommitdiffstats
path: root/package/divine
diff options
context:
space:
mode:
Diffstat (limited to 'package/divine')
-rw-r--r--package/divine/Config.in8
-rw-r--r--package/divine/divine.mk14
2 files changed, 22 insertions, 0 deletions
diff --git a/package/divine/Config.in b/package/divine/Config.in
new file mode 100644
index 000000000..820229214
--- /dev/null
+++ b/package/divine/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_DIVINE
+ bool "directfb virtual input extension"
+ depends on BR2_PACKAGE_DIRECTFB
+ help
+ DiVine provides a DirectFB input driver that reads input
+ events from a pipe and dispatches them via a virtual input
+ device. It also installs the tool 'spooky' that allows to
+ send input events to DirectFB applications.
diff --git a/package/divine/divine.mk b/package/divine/divine.mk
new file mode 100644
index 000000000..554ee63a6
--- /dev/null
+++ b/package/divine/divine.mk
@@ -0,0 +1,14 @@
+#############################################################
+#
+# divine
+#
+#############################################################
+
+DIVINE_VERSION := 0.4.0
+DIVINE_SITE := http://www.directfb.org/downloads/Extras
+DIVINE_SOURCE = DiVine-$(DIVINE_VERSION).tar.gz
+DIVINE_INSTALL_STAGING = YES
+DIVINE_INSTALL_TARGET = YES
+DIVINE_DEPENDENCIES = directfb
+
+$(eval $(call AUTOTARGETS,package,divine))