summaryrefslogtreecommitdiffstats
path: root/package/cups
diff options
context:
space:
mode:
Diffstat (limited to 'package/cups')
-rw-r--r--package/cups/Config.in13
-rw-r--r--package/cups/cups.mk6
2 files changed, 19 insertions, 0 deletions
diff --git a/package/cups/Config.in b/package/cups/Config.in
index 8b1f8a5b4..0176423a1 100644
--- a/package/cups/Config.in
+++ b/package/cups/Config.in
@@ -4,3 +4,16 @@ config BR2_PACKAGE_CUPS
The Common Unix Printing System
http://www.cups.org
+
+if BR2_PACKAGE_CUPS
+
+config BR2_PACKAGE_CUPS_PDFTOPS
+ bool "pdftops support"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Enable pdftops support
+
+comment "pdftops support requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
+
+endif
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index e3d6f78d1..d1bf0fa20 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -58,6 +58,12 @@ else
CUPS_CONF_OPT += --disable-python
endif
+ifeq ($(BR2_PACKAGE_CUPS_PDFTOPS),y)
+ CUPS_CONF_OPT += --enable-pdftops
+else
+ CUPS_CONF_OPT += --disable-pdftops
+endif
+
$(DL_DIR)/$(CUPS_SOURCE):
$(call DOWNLOAD,$(CUPS_SITE),$(CUPS_SOURCE))