summaryrefslogtreecommitdiffstats
path: root/package/cups
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-05-14 17:03:23 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-05-14 17:03:23 +0200
commit0a761ca8aa838cab26ec9792745c38ca2a13f52d (patch)
treee700f241012c9872c5ebb0d5f7f6e244839dff54 /package/cups
parent419257b191d71bd50f6b8a561a5d79a6f688f5a6 (diff)
downloadbuildroot-novena-0a761ca8aa838cab26ec9792745c38ca2a13f52d.tar.gz
buildroot-novena-0a761ca8aa838cab26ec9792745c38ca2a13f52d.zip
cups: add pdftops option
The pdftops support in cups needs C++ support, whereas the rest doesn't. Add a BR2_PACKAGE_CUPS_PDFTOPS (depending on C++ support) to enable it if needed. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/cups')
-rw-r--r--package/cups/Config.in13
-rw-r--r--package/cups/cups.mk6
2 files changed, 19 insertions, 0 deletions
diff --git a/package/cups/Config.in b/package/cups/Config.in
index 8b1f8a5b4..0176423a1 100644
--- a/package/cups/Config.in
+++ b/package/cups/Config.in
@@ -4,3 +4,16 @@ config BR2_PACKAGE_CUPS
The Common Unix Printing System
http://www.cups.org
+
+if BR2_PACKAGE_CUPS
+
+config BR2_PACKAGE_CUPS_PDFTOPS
+ bool "pdftops support"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Enable pdftops support
+
+comment "pdftops support requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
+
+endif
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index e3d6f78d1..d1bf0fa20 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -58,6 +58,12 @@ else
CUPS_CONF_OPT += --disable-python
endif
+ifeq ($(BR2_PACKAGE_CUPS_PDFTOPS),y)
+ CUPS_CONF_OPT += --enable-pdftops
+else
+ CUPS_CONF_OPT += --disable-pdftops
+endif
+
$(DL_DIR)/$(CUPS_SOURCE):
$(call DOWNLOAD,$(CUPS_SITE),$(CUPS_SOURCE))