summaryrefslogtreecommitdiffstats
path: root/package/cups/cups.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/cups/cups.mk')
-rw-r--r--package/cups/cups.mk14
1 files changed, 4 insertions, 10 deletions
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index 2357306d3..c19ae0cbc 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -28,17 +28,11 @@ ifeq ($(BR2_PACKAGE_XORG7),y)
endif
ifeq ($(BR2_PACKAGE_PHP),y)
- CUPS_CFLAGS += -I$(STAGING_DIR)/usr/include/php
- CUPS_CFLAGS += -I$(STAGING_DIR)/usr/include/php/main
- CUPS_CFLAGS += -I$(STAGING_DIR)/usr/include/php/regex
- CUPS_CFLAGS += -I$(STAGING_DIR)/usr/include/php/TSRM
- CUPS_CFLAGS += -I$(STAGING_DIR)/usr/include/php/Zend
- CUPS_CFLAGS += -I$(STAGING_DIR)/usr/include/php/ext
- CUPS_CONF_ENV += ac_cv_path_php=$(STAGING_DIR)/usr/bin/php
- CUPS_CONF_OPT += --with-php
- CUPS_DEPENDENCIES += php
+ CUPS_CONF_ENV += ac_cv_path_PHPCONFIG=$(STAGING_DIR)/usr/bin/php-config
+ CUPS_CONF_OPT += --with-php
+ CUPS_DEPENDENCIES += php
else
- CUPS_CONF_OPT += --without-php
+ CUPS_CONF_OPT += --without-php
endif
ifeq ($(BR2_PACKAGE_PYTHON),y)