summaryrefslogtreecommitdiffstats
path: root/package/cppzmq
diff options
context:
space:
mode:
Diffstat (limited to 'package/cppzmq')
-rw-r--r--package/cppzmq/Config.in15
-rw-r--r--package/cppzmq/cppzmq.mk23
2 files changed, 38 insertions, 0 deletions
diff --git a/package/cppzmq/Config.in b/package/cppzmq/Config.in
new file mode 100644
index 000000000..ea632d143
--- /dev/null
+++ b/package/cppzmq/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_CPPZMQ
+ bool "cppzmq"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_INET_IPV6 # zeromq
+ depends on BR2_LARGEFILE # util-linux
+ depends on BR2_USE_WCHAR # util-linux
+ select BR2_PACKAGE_ZEROMQ
+ help
+ C++ binding for zeromq (ZeroMQ, 0MQ, zmq).
+
+ http://github.com/zeromq/cppzmq
+
+comment "cppzmq requires a toolchain with C++, IPV6, LARGEFILE and WCHAR support"
+ depends on !(BR2_INSTALL_LIBSTDCPP && BR2_INET_IPV6 && BR2_LARGEFILE \
+ && BR2_USE_WCHAR)
diff --git a/package/cppzmq/cppzmq.mk b/package/cppzmq/cppzmq.mk
new file mode 100644
index 000000000..d4609bf23
--- /dev/null
+++ b/package/cppzmq/cppzmq.mk
@@ -0,0 +1,23 @@
+#############################################################
+#
+# cppzmq
+#
+#############################################################
+
+CPPZMQ_VERSION = b232978
+CPPZMQ_SITE = git://github.com/zeromq/cppzmq.git
+CPPZMQ_INSTALL_STAGING = YES
+CPPZMQ_DEPENDENCIES = zeromq
+CPPZMQ_LICENSE = MIT
+# No license file, the license is in the installed header
+CPPZMQ_LICENSE_FILES = zmq.hpp
+
+define CPPZMQ_INSTALL_STAGING_CMDS
+ $(INSTALL) -m 0644 -D $(@D)/zmq.hpp $(STAGING_DIR)/usr/include/zmq.hpp
+endef
+
+define CPPZMQ_UNINSTALL_STAGING_CMDS
+ $(RM) $(STAGING_DIR)/usr/include/zmq.hpp
+endef
+
+$(eval $(generic-package))