summaryrefslogtreecommitdiffstats
path: root/package/coreutils/coreutils.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/coreutils/coreutils.mk')
-rw-r--r--package/coreutils/coreutils.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index ae8863f5d..d934ae896 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -54,6 +54,14 @@ COREUTILS_CONF_OPT = --disable-rpath \
--disable-dependency-tracking \
--enable-install-program=hostname
+define COREUTILS_TOUCH_UNAME_C
+ # ensure uname.c file's timestamp does not change,
+ # so help2man does not run
+ touch -d '2010-01-01' $(@D)/src/uname.c
+endef
+
+COREUTILS_POST_PATCH_HOOKS += COREUTILS_TOUCH_UNAME_C
+
define COREUTILS_POST_INSTALL
# some things go in root rather than usr
for f in $(COREUTILS_BIN_PROGS); do \