summaryrefslogtreecommitdiffstats
path: root/package/copas/copas.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/copas/copas.mk')
-rw-r--r--package/copas/copas.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/copas/copas.mk b/package/copas/copas.mk
new file mode 100644
index 000000000..1baed8356
--- /dev/null
+++ b/package/copas/copas.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# copas
+#
+#############################################################
+
+COPAS_VERSION = 1.1.6
+COPAS_SITE = http://github.com/downloads/keplerproject/copas
+COPAS_DEPENDENCIES = lua coxpcall luasocket
+
+define COPAS_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0644 -D $(@D)/src/copas/copas.lua \
+ $(TARGET_DIR)/usr/share/lua/copas.lua
+endef
+
+define COPAS_UNINSTALL_TARGET_CMDS
+ rm -f "$(TARGET_DIR)/usr/share/lua/copas.lua"
+endef
+
+$(eval $(call GENTARGETS,package,copas))