summaryrefslogtreecommitdiffstats
path: root/package/boost/boost.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/boost/boost.mk')
-rw-r--r--package/boost/boost.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 57d021ae4..ce729901a 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -12,7 +12,7 @@ BOOST_INSTALL_STAGING = YES
TARGET_CC_VERSION = $(shell $(TARGET_CC) -dumpversion)
-BOOST_DEPENDENCIES = bzip2 zlib
+BOOST_DEPENDENCIES =
BOOST_FLAGS =
@@ -48,6 +48,10 @@ else
BOOST_FLAGS += --without-icu
endif
+ifeq ($(BR2_PACKAGE_BOOST_IOSTREAMS),y)
+BOOST_DEPENDENCIES += bzip2 zlib
+endif
+
BOOST_OPT += toolset=gcc \
threading=multi \
variant=$(if $(BR2_ENABLE_DEBUG),debug,release) \