summaryrefslogtreecommitdiffstats
path: root/package/binutils/binutils.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/binutils/binutils.mk')
-rw-r--r--package/binutils/binutils.mk24
1 files changed, 13 insertions, 11 deletions
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 5123568ec..20de45a85 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -4,7 +4,13 @@
#
#############################################################
+# Version is set when using buildroot toolchain.
+# If not, we do like other packages
BINUTILS_VERSION = $(call qstrip,$(BR2_BINUTILS_VERSION))
+ifeq ($(BINUTILS_VERSION),)
+BINUTILS_VERSION = 2.21
+endif
+
BINUTILS_SOURCE = binutils-$(BINUTILS_VERSION).tar.bz2
BINUTILS_SITE = $(BR2_GNU_MIRROR)/binutils
ifeq ($(ARCH),avr32)
@@ -34,23 +40,19 @@ HOST_BINUTILS_CONF_OPT = --disable-multilib --disable-werror \
$(BR2_CONFIGURE_STAGING_SYSROOT) \
$(BINUTILS_EXTRA_CONFIG_OPTIONS)
-# We just want libbfd, not the full-blown binutils in staging
+# We just want libbfd and libiberty, not the full-blown binutils in staging
define BINUTILS_INSTALL_STAGING_CMDS
$(MAKE) -C $(@D)/bfd DESTDIR=$(STAGING_DIR) install
+ $(MAKE) -C $(@D)/libiberty DESTDIR=$(STAGING_DIR) install
endef
-# only libbfd in the target...
-BINUTILS_INSTALL_FROM = $(@D)/bfd
-
-# unless we want full...
-ifeq ($(BR2_PACKAGE_BINUTILS_TARGET),y)
-BINUTILS_INSTALL_FROM = $(@D)
-endif
-
+# If we don't want full binutils on target
+ifneq ($(BR2_PACKAGE_BINUTILS_TARGET),y)
define BINUTILS_INSTALL_TARGET_CMDS
- $(TARGET_MAKE_ENV) $(MAKE) -C $(BINUTILS_INSTALL_FROM) \
- DESTDIR=$(TARGET_DIR) install
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/bfd DESTDIR=$(TARGET_DIR) install
+ $(MAKE) -C $(@D)/libiberty DESTDIR=$(STAGING_DIR) install
endef
+endif
$(eval $(call AUTOTARGETS))
$(eval $(call AUTOTARGETS,host))