summaryrefslogtreecommitdiffstats
path: root/package/avahi/avahi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/avahi/avahi.mk')
-rw-r--r--package/avahi/avahi.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index e4b34a072..77f4f3601 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -92,7 +92,7 @@ AVAHI_CONF_OPT = --localstatedir=/var \
--with-autoipd-user=default \
--with-autoipd-group=default
-AVAHI_DEPENDENCIES = $(if $(BR2_ENABLE_LOCALE),gettext libintl)
+AVAHI_DEPENDENCIES = $(if $(BR2_PACKAGE_GETTEXT),gettext)
ifneq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_AVAHI_AUTOIPD),)
AVAHI_DEPENDENCIES += libdaemon
@@ -113,7 +113,8 @@ else
AVAHI_CONF_OPT += --disable-dbus
endif
-ifeq ($(BR2_ENABLE_LOCALE),y)
+ifeq ($(BR2_PACKAGE_LIBINTL),y)
+AVAHI_DEPENDENCIES += libintl
AVAHI_MAKE_OPT = LIBS=-lintl
endif