summaryrefslogtreecommitdiffstats
path: root/package/avahi/avahi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/avahi/avahi.mk')
-rw-r--r--package/avahi/avahi.mk15
1 files changed, 12 insertions, 3 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 032edfd6a..72e94102a 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -72,11 +72,8 @@ AVAHI_CONF_ENV = ac_cv_func_strtod=yes \
avahi_cv_sys_cxx_works=yes
AVAHI_CONF_OPT = --localstatedir=/var \
- --disable-glib \
- --disable-gobject \
--disable-qt3 \
--disable-qt4 \
- --disable-gtk \
--disable-gdbm \
--disable-python-dbus \
--disable-pygtk \
@@ -112,6 +109,18 @@ else
AVAHI_CONF_OPT += --disable-dbus
endif
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+AVAHI_DEPENDENCIES += libglib2
+else
+AVAHI_CONF_OPT += --disable-glib --disable-gobject
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGTK2),y)
+AVAHI_DEPENDENCIES += libgtk2
+else
+AVAHI_CONF_OPT += --disable-gtk
+endif
+
ifeq ($(BR2_PACKAGE_PYTHON),y)
AVAHI_CONF_ENV += am_cv_pathless_PYTHON=python \
am_cv_path_PYTHON=$(PYTHON_TARGET_BINARY) \