summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in5
-rw-r--r--linux/linux.mk7
2 files changed, 8 insertions, 4 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 910d9a524..9ebe0c963 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -261,11 +261,12 @@ config BR2_LINUX_KERNEL_USE_CUSTOM_DTS
endchoice
config BR2_LINUX_KERNEL_INTREE_DTS_NAME
- string "Device Tree Source file name"
+ string "Device Tree Source file names"
depends on BR2_LINUX_KERNEL_USE_INTREE_DTS
help
Name of the device tree source file, without
- the trailing .dts
+ the trailing .dts. You can provide a list of
+ dts files to build, separated by spaces.
config BR2_LINUX_KERNEL_CUSTOM_DTS_PATH
string "Device Tree Source file path"
diff --git a/linux/linux.mk b/linux/linux.mk
index c4bdf9090..3321d809a 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -187,10 +187,13 @@ endef
ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT),y)
ifeq ($(BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT),)
define LINUX_BUILD_DTB
- $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(KERNEL_DTS_NAME).dtb
+ $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) \
+ $(addsuffix .dtb, $(call qstrip, $(KERNEL_DTS_NAME)))
endef
define LINUX_INSTALL_DTB
- cp $(KERNEL_ARCH_PATH)/boot/$(KERNEL_DTS_NAME).dtb $(BINARIES_DIR)/
+ cp $(addprefix $(KERNEL_ARCH_PATH)/boot/, \
+ $(addsuffix .dtb, $(call qstrip, $(KERNEL_DTS_NAME)))) \
+ $(BINARIES_DIR)/
endef
endif
endif